<!DOCTYPE html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1.0">
  <link rel="profile" href="http://gmpg.org/xfn/11">
  <link rel="pingback" href="https://wptsradio.org/xmlrpc.php">

  <title>WPTS&#039;s Top 50 Albums of 2018 - WPTS Radio</title>
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>

<!-- This site is optimized with the Yoast SEO plugin v7.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="As End of the year list season comes to a close, it&#039;s time for WPTS&#039;s 50 favorite albums. 2018 was a really exciting year for music, with a number of great releases across a number of styles. So, without further ado, here are WPTS&#039;s highlights:"/>
<link rel="canonical" href="https://wptsradio.org/wptss-top-50-albums-of-2018/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="WPTS&#039;s Top 50 Albums of 2018 - WPTS Radio" />
<meta property="og:description" content="As End of the year list season comes to a close, it&#039;s time for WPTS&#039;s 50 favorite albums. 2018 was a really exciting year for music, with a number of great releases across a number of styles. So, without further ado, here are WPTS&#039;s highlights:" />
<meta property="og:url" content="https://wptsradio.org/wptss-top-50-albums-of-2018/" />
<meta property="og:site_name" content="WPTS Radio" />
<meta property="article:publisher" content="https://www.facebook.com/wptsradiofm/" />
<meta property="article:tag" content="Beach House" />
<meta property="article:tag" content="Blood Orange" />
<meta property="article:tag" content="Boy Pablo" />
<meta property="article:tag" content="boygenius" />
<meta property="article:tag" content="Brockhampton" />
<meta property="article:tag" content="car seat headrest" />
<meta property="article:tag" content="Caroline Rose" />
<meta property="article:tag" content="Courtney Barnett" />
<meta property="article:tag" content="current joys" />
<meta property="article:tag" content="Denzel Curry" />
<meta property="article:tag" content="Earl Sweatshirt" />
<meta property="article:tag" content="End of the year" />
<meta property="article:tag" content="Gobbinjr" />
<meta property="article:tag" content="Guerilla Toss" />
<meta property="article:tag" content="homesafe" />
<meta property="article:tag" content="Jack Stauber" />
<meta property="article:tag" content="Janelle Monae" />
<meta property="article:tag" content="JID" />
<meta property="article:tag" content="JPEGMAFIA" />
<meta property="article:tag" content="Kali Uchis" />
<meta property="article:tag" content="Kero Kero Bonito" />
<meta property="article:tag" content="Lala Lala" />
<meta property="article:tag" content="Lets Eat Grandma" />
<meta property="article:tag" content="list" />
<meta property="article:tag" content="Liz Cooper and the Stampede" />
<meta property="article:tag" content="Lucy Dacus" />
<meta property="article:tag" content="Mac Miller" />
<meta property="article:tag" content="merce lemon" />
<meta property="article:tag" content="Mid-Air Thief" />
<meta property="article:tag" content="Mitski" />
<meta property="article:tag" content="Mom Jeans" />
<meta property="article:tag" content="Mourn" />
<meta property="article:tag" content="music staff" />
<meta property="article:tag" content="Noname" />
<meta property="article:tag" content="oh sees" />
<meta property="article:tag" content="parquet courts" />
<meta property="article:tag" content="Playboi Carti" />
<meta property="article:tag" content="Pusha-T" />
<meta property="article:tag" content="Rejjie Snow" />
<meta property="article:tag" content="Rivers of Nihil" />
<meta property="article:tag" content="Saba" />
<meta property="article:tag" content="Save Face" />
<meta property="article:tag" content="Sidney Gish" />
<meta property="article:tag" content="snail mail" />
<meta property="article:tag" content="soccer mommy" />
<meta property="article:tag" content="Sonder Bombs" />
<meta property="article:tag" content="Spiritualized" />
<meta property="article:tag" content="The Punch Brothers" />
<meta property="article:tag" content="Tierra Whack" />
<meta property="article:tag" content="top albums" />
<meta property="article:tag" content="Treble NLS" />
<meta property="article:tag" content="Water Trash" />
<meta property="article:tag" content="Young Fathers" />
<meta property="article:tag" content="Yves Tumor" />
<meta property="article:section" content="General Station" />
<meta property="article:published_time" content="2018-12-31T12:00:44-05:00" />
<meta property="article:modified_time" content="2018-12-31T16:28:56-05:00" />
<meta property="og:updated_time" content="2018-12-31T16:28:56-05:00" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/02/loner.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/02/loner.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/earl_some-rap-songs-300x300.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/earl_some-rap-songs-300x300.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/YOUNG_FATHERS_PACKSHOT_RGB_3000X3000_small.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/YOUNG_FATHERS_PACKSHOT_RGB_3000X3000_small.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/03/Rivers-of-Nihil.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/03/Rivers-of-Nihil.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/janelle.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/janelle.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/OH-SEES.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/OH-SEES.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/11/https_2F2Fimages.genius.com2F5da37b77be2204a52bd0433c6650f563.1000x1000x1.png" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/11/https_2F2Fimages.genius.com2F5da37b77be2204a52bd0433c6650f563.1000x1000x1.png" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/Guerilla.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/Guerilla.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/09/liz-cooper-window-flowers.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/09/liz-cooper-window-flowers.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/09/homesafe-one.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/09/homesafe-one.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/modern_female_rockstar-300x300.png" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/modern_female_rockstar-300x300.png" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/punch.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/punch.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/dear.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/dear.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/no-dice.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/no-dice.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/mom-jeans.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/mom-jeans.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/Spirtualized_And-Nothing-Hurt.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/Spirtualized_And-Nothing-Hurt.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/mid-air-thief.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/mid-air-thief.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/11/BoyPabloCover.jpeg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/11/BoyPabloCover.jpeg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/safeinthehands.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/safeinthehands.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/Tierra-Whack_Whack-World-EP.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/Tierra-Whack_Whack-World-EP.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/03/Car-Seat-Headrest.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/03/Car-Seat-Headrest.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/a32cd99ccc7ef74ab3e82d30e8b8389a.1000x1000x1.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/a32cd99ccc7ef74ab3e82d30e8b8389a.1000x1000x1.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/die-lit-playboi-carti-hi-res-cover.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/die-lit-playboi-carti-hi-res-cover.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/sfm.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/sfm.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/mourn.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/mourn.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/denz.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/denz.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/07/LetsEatGrandamaImAllEars.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/07/LetsEatGrandamaImAllEars.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/kkb.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/kkb.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/boygeniusAlbumCover.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/boygeniusAlbumCover.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/Saba_-Care-For-Me.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/Saba_-Care-For-Me.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/Tell-Me-How-You-Really-Feel.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/Tell-Me-How-You-Really-Feel.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/gob.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/gob.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/07/snail-mail-album-cover.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/07/snail-mail-album-cover.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/kali.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/kali.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/07/GirlsWhoJumpIn.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/07/GirlsWhoJumpIn.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/03/Lucy-Dacus.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/03/Lucy-Dacus.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/03/Soccer-Mommy.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/03/Soccer-Mommy.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/07/Daytona.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/07/Daytona.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/03/sidney-gish-no-dogs-allowed.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/03/sidney-gish-no-dogs-allowed.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/03/current-joys.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/03/current-joys.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/hilo.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/hilo.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/jid.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/jid.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/09/blood-orange_negro-swan.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/09/blood-orange_negro-swan.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/lala-lala_the-lamb.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/lala-lala_the-lamb.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/jpeg.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/jpeg.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/05/Parquet-Courts.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/05/Parquet-Courts.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/05/BeachHouse7.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/05/BeachHouse7.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/12/Mac-Miller_Swimming.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/12/Mac-Miller_Swimming.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/08/be-the-cowboy.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/08/be-the-cowboy.jpg" />
<meta property="og:image" content="https://wptsradio.org/wp-content/uploads/2018/09/noname-room-25.jpg" />
<meta property="og:image:secure_url" content="https://wptsradio.org/wp-content/uploads/2018/09/noname-room-25.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="As End of the year list season comes to a close, it&#039;s time for WPTS&#039;s 50 favorite albums. 2018 was a really exciting year for music, with a number of great releases across a number of styles. So, without further ado, here are WPTS&#039;s highlights:" />
<meta name="twitter:title" content="WPTS&#039;s Top 50 Albums of 2018 - WPTS Radio" />
<meta name="twitter:site" content="@wptsradio" />
<meta name="twitter:creator" content="@wptsradio" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/wptsradio.org\/","sameAs":["https:\/\/www.facebook.com\/wptsradiofm\/","https:\/\/www.instagram.com\/wpts\/","https:\/\/www.youtube.com\/user\/921WPTS","https:\/\/twitter.com\/wptsradio"],"@id":"#organization","name":"WPTS Radio","logo":"https:\/\/wptsradio.org\/wp-content\/uploads\/2015\/12\/WPTS-Square-Logo.png"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WPTS Radio &raquo; Feed" href="https://wptsradio.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="WPTS Radio &raquo; Comments Feed" href="https://wptsradio.org/comments/feed/" />
<link id="hu-user-gfont" href="//fonts.googleapis.com/css?family=Source+Sans+Pro:400,300italic,300,400italic,600&subset=latin,latin-ext" rel="stylesheet" type="text/css"><link rel="alternate" type="application/rss+xml" title="WPTS Radio &raquo; WPTS&#8217;s Top 50 Albums of 2018 Comments Feed" href="https://wptsradio.org/wptss-top-50-albums-of-2018/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.0.6 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-23827780-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-23827780-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/wptsradio.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-color-picker-css'  href='https://wptsradio.org/wp-admin/css/color-picker.min.css?ver=4.8.8' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://wptsradio.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.4' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-css'  href='https://wptsradio.org/wp-content/plugins/form-maker/css/jquery-ui-1.10.3.custom.css?ver=4.8.8' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-spinner-css'  href='https://wptsradio.org/wp-content/plugins/form-maker/css/jquery-ui-spinner.css?ver=4.8.8' type='text/css' media='all' />
<link rel='stylesheet' id='form_maker_calendar-jos-css'  href='https://wptsradio.org/wp-content/plugins/form-maker/css/calendar-jos.css?ver=4.8.8' type='text/css' media='all' />
<link rel='stylesheet' id='form_maker_frontend-css'  href='https://wptsradio.org/wp-content/plugins/form-maker/css/form_maker_frontend.css?ver=4.8.8' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-lightbox-swipebox-css'  href='https://wptsradio.org/wp-content/plugins/responsive-lightbox/assets/swipebox/css/swipebox.min.css?ver=1.6.7' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-file-upload-style-css'  href='https://wptsradio.org/wp-content/plugins/wp-file-upload/css/wordpress_file_upload_style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-file-upload-style-safe-css'  href='https://wptsradio.org/wp-content/plugins/wp-file-upload/css/wordpress_file_upload_style_safe.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-css-css'  href='//code.jquery.com/ui/1.11.4/themes/smoothness/jquery-ui.css?ver=4.8.8' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-timepicker-addon-css-css'  href='https://wptsradio.org/wp-content/plugins/wp-file-upload/vendor/datetimepicker/jquery-ui-timepicker-addon.min.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css'  href='https://wptsradio.org/wp-content/themes/hueman/assets/front/css/main.min.css?ver=3.3.22' type='text/css' media='all' />
<style id='hueman-main-style-inline-css' type='text/css'>
body { font-family:'Source Sans Pro', Arial, sans-serif;font-size:1.00rem }@media only screen and (min-width: 720px) {
        .nav > li { font-size:1.00rem; }
      }::selection { background-color: #cacece; }
::-moz-selection { background-color: #cacece; }a,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #cacece; }.themeform input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #cacece; }.post-format .format-container { border-color: #cacece; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #cacece!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #bababa; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #bababa; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #bababa; }
.post-comments span:before { border-right-color: #bababa; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #0c2340}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #0c2340; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #0c2340; background-color: rgba(12,35,64,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #0c2340; background-color: rgba(12,35,64,0.95) }#header { background-color: #0c2340; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #0c2340; }
}
        #header #nav-mobile { background-color: #0c2340; }.is-scrolled #header #nav-mobile { background-color: #0c2340; background-color: rgba(12,35,64,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: #b3a369; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #b3a369; }
}
        #footer-bottom { background-color: #b3a369; }.site-title a img { max-height: 200px; }img { -webkit-border-radius: 12px; border-radius: 12px; }body { background-color: #0c2340; }
</style>
<link rel='stylesheet' id='hueman-font-awesome-css'  href='https://wptsradio.org/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?ver=3.3.22' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-qtip-css'  href='https://wptsradio.org/wp-content/plugins/google-calendar-events/assets/css/vendor/jquery.qtip.min.css?ver=3.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-grid-css'  href='https://wptsradio.org/wp-content/plugins/google-calendar-events/assets/css/default-calendar-grid.min.css?ver=3.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='simcal-default-calendar-list-css'  href='https://wptsradio.org/wp-content/plugins/google-calendar-events/assets/css/default-calendar-list.min.css?ver=3.1.10' type='text/css' media='all' />
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/events-calendar/js/jquery.bgiframe.js?ver=2.1'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/events-calendar/js/jquery.tooltip.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/google-calendar-widget/wiky.js?ver=1.0'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/google-calendar-widget/date.js?ver=alpha-1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ko_calendar_loc = {"all_day":"All Day","all_day_event":"All Day Event"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/google-calendar-widget/ko-calendar.js?ver=4.8.8'></script>
<script type='text/javascript' src='//apis.google.com/js/client.js?onload=ko_calendar_google_init&#038;ver=4.8.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/wptsradio.org","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.0.6'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/form-maker/js/if_gmap_front_end.js?ver=4.8.8'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/form-maker/js/jelly.min.js?ver=4.8.8'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/form-maker/js/file-upload.js?ver=4.8.8'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/form-maker/js/calendar/calendar.js?ver=4.8.8'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/form-maker/js/calendar/calendar_function.js?ver=4.8.8'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/responsive-lightbox/assets/swipebox/js/jquery.swipebox.min.js?ver=1.6.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var rlArgs = {"script":"swipebox","selector":"lightbox","customEvents":"","activeGalleries":"1","animation":"1","hideCloseButtonOnMobile":"0","removeBarsOnMobile":"0","hideBars":"1","hideBarsDelay":"5000","videoMaxWidth":"1080","useSVG":"1","loopAtEnd":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/responsive-lightbox/js/front.js?ver=1.6.7'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/wp-file-upload/js/json2.js?ver=4.8.8'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/wp-file-upload/js/wordpress_file_upload_functions.js?ver=4.8.8'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/themes/hueman/assets/front/js/libs/mobile-detect.min.js?ver=4.8.8'></script>
<link rel='https://api.w.org/' href='https://wptsradio.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://wptsradio.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://wptsradio.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.8" />
<meta name="generator" content="Seriously Simple Podcasting 1.16.4" />
<link rel='shortlink' href='https://wptsradio.org/?p=25444' />
<link rel="alternate" type="application/json+oembed" href="https://wptsradio.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwptsradio.org%2Fwptss-top-50-albums-of-2018%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://wptsradio.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwptsradio.org%2Fwptss-top-50-albums-of-2018%2F&#038;format=xml" />
<script type="text/javascript" src="httpss://wptsradio.org/wp-content/plugins/audio-player/assets/audio-player.js?ver=2.0.4.6"></script>
<script type="text/javascript">AudioPlayer.setup("httpss://wptsradio.org/wp-content/plugins/audio-player/assets/player.swf?ver=2.0.4.6", {width:"290",animation:"yes",encode:"yes",initialvolume:"60",remaining:"no",noinfo:"no",buffer:"5",checkpolicy:"no",rtl:"no",bg:"757575",text:"333333",leftbg:"999999",lefticon:"ffffff",volslider:"666666",voltrack:"FFFFFF",rightbg:"999999",rightbghover:"999999",righticon:"f6f6f6",righticonhover:"FFFFFF",track:"FFFFFF",loader:"4C8EB9",border:"CCCCCC",tracker:"DDDDDD",skip:"666666",pagebg:"FFFFFF",transparentpagebg:"yes"});</script>
<!-- Start Of Script Generated By Events-Calendar [Luke Howell | www.lukehowell.com] and [R. MALKA | www.heirem.fr] -->
<!-- More information at http://wp-eventscalendar.com. -->
<link type="text/css" rel="stylesheet" href="https://wptsradio.org/wp-includes/js/thickbox/thickbox.css" />
<link type="text/css" rel="stylesheet" href="https://wptsradio.org/wp-content/plugins/events-calendar/css/events-calendar.css" />
 <script type="text/javascript">
	// <![CDATA[
	var ecd = {};
	ecd.jq = jQuery.noConflict(false);
	//]]>
 </script>
<!-- End Of Script Generated By Events-Calendar - Version: 6.7.6 -->
<link type="text/css" rel="stylesheet" href="https://wptsradio.org/wp-content/plugins/google-calendar-widget/ko-calendar.css" />            <script type="text/javascript" id="ha-customize-btn">
              jQuery( function($) {
                  $( "#wp-admin-bar-customize").find('a').attr('title', 'Customize this page !' );
              });
            </script>
            <style type="text/css" id="ha-fun-ab">
              @-webkit-keyframes super-rainbow {
                0%   { text-shadow : 0px 0px 2px;}
                20%  { text-shadow : 0px 0px 5px; }
                40%  { text-shadow : 0px 0px 10px; }
                60%  { text-shadow : 0px 0px 13px }
                80%  { text-shadow : 0px 0px 10px; }
                100% { text-shadow : 0px 0px 5px; }
              }
              @-moz-keyframes super-rainbow {
                0%   { text-shadow : 0px 0px 2px;}
                20%  { text-shadow : 0px 0px 5px; }
                40%  { text-shadow : 0px 0px 10px; }
                60%  { text-shadow : 0px 0px 13px }
                80%  { text-shadow : 0px 0px 10px; }
                100% { text-shadow : 0px 0px 5px; }
              }

              #wp-admin-bar-customize .ab-item:before {
                  color:#7ECEFD;
                  -webkit-animation: super-rainbow 4s infinite linear;
                   -moz-animation: super-rainbow 4s infinite linear;
              }
            </style>
        
<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://wptsradio.org/feed/podcast" />

<!--[if lt IE 9]>
<script src="https://wptsradio.org/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="https://wptsradio.org/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->
<link rel="icon" href="https://wptsradio.org/wp-content/uploads/2017/05/cropped-Wide-Video-Logo-e1494608755699-150x150.png" sizes="32x32" />
<link rel="icon" href="https://wptsradio.org/wp-content/uploads/2017/05/cropped-Wide-Video-Logo-e1494608755699-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://wptsradio.org/wp-content/uploads/2017/05/cropped-Wide-Video-Logo-e1494608755699-300x300.png" />
<meta name="msapplication-TileImage" content="https://wptsradio.org/wp-content/uploads/2017/05/cropped-Wide-Video-Logo-e1494608755699-300x300.png" />
		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.

Use this field to test small chunks of CSS code. For important CSS customizations, it is recommended to modify the style.css file of a child theme.
http//codex.wordpress.org/Child_Themes
*/
		</style>
	</head>

<body class="post-template-default single single-post postid-25444 single-format-standard wp-custom-logo col-3cm full-width header-desktop-sticky header-mobile-sticky unknown">

<div id="wrapper">

  
  <header id="header" class="specific-mobile-menu-on one-mobile-menu mobile_menu header-ads-desktop  topbar-transparent no-header-img">
        <nav class="nav-container group mobile-menu mobile-sticky no-menu-assigned" id="nav-mobile" data-menu-id="header-1">
  <div class="mobile-title-logo-in-header">                  <p class="site-title"><a class="custom-logo-link" href="https://wptsradio.org/" rel="home" title="WPTS Radio | Home page"><img src="https://wptsradio.org/wp-content/uploads/2017/05/Final-Banner.png" alt="WPTS Radio"></a></p>
                </div>
        
                    <div class="nav-toggle"><i class="fa fa-bars"></i></div>
            
      <div class="nav-text"></div>
      <div class="nav-wrap container">
                  <ul class="nav container-inner group mobile-search">
                            <li>
                  <form method="get" class="searchform themeform" action="https://wptsradio.org/">
	<div>
		<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
	</div>
</form>                </li>
                      </ul>
                <ul id="menu-main-menu" class="nav container-inner group"><li id="menu-item-16534" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16534"><a href="https://wptsradio.org/listen/">Listen</a></li>
<li id="menu-item-16529" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-16529"><a href="https://wptsradio.org/about/">About</a>
<ul  class="sub-menu">
	<li id="menu-item-16531" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16531"><a href="https://wptsradio.org/contact/staff/">Staff</a></li>
	<li id="menu-item-19744" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19744"><a href="https://wptsradio.org/showschedule/">Full Show Schedule</a></li>
	<li id="menu-item-16532" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16532"><a href="https://wptsradio.org/contacting-the-station/">Contacting the Station</a></li>
	<li id="menu-item-20991" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20991"><a href="https://wptsradio.org/about/mission-vision-values/">Mission, Vision, Values</a></li>
</ul>
</li>
<li id="menu-item-23569" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23569"><a href="https://wptsradio.org/get-involved/">Connect</a></li>
<li id="menu-item-16537" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16537"><a href="https://wptsradio.org/dept/archives/">Music</a></li>
<li id="menu-item-22206" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22206"><a href="https://wptsradio.org/dept/news-department/">News</a></li>
<li id="menu-item-16558" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16558"><a href="https://wptsradio.org/dept/sports/">Sports</a>
<ul  class="sub-menu">
	<li id="menu-item-25324" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25324"><a href="https://wptsradio.org/dept/sports/pitt-60/">Pitt60</a></li>
</ul>
</li>
<li id="menu-item-25365" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25365"><a href="https://wptsradio.org/podcasts/">Podcasts</a></li>
<li id="menu-item-24490" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24490"><a href="https://wptsradio.org/dept/events/">Events</a></li>
</ul>      </div>
</nav><!--/#nav-topbar-->  
  
  <div class="container group">
        <div class="container-inner">

                    <div class="group pad central-header-zone">
                  <div class="logo-tagline-group">
                                        <p class="site-title"><a class="custom-logo-link" href="https://wptsradio.org/" rel="home" title="WPTS Radio | Home page"><img src="https://wptsradio.org/wp-content/uploads/2017/05/Final-Banner.png" alt="WPTS Radio"></a></p>
                                                                <p class="site-description"></p>
                                        </div>

                                </div>
      
                <nav class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-2">
    <div class="nav-text"><!-- put your mobile menu text here --></div>

  <div class="nav-wrap container">
          <div id="main-header-search" class="container">
        <div class="container-inner">
          <div class="toggle-search"><i class="fa fa-search"></i></div>
          <div class="search-expand">
            <div class="search-expand-inner"><form method="get" class="searchform themeform" action="https://wptsradio.org/">
	<div>
		<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
	</div>
</form></div>
          </div>
        </div><!--/.container-inner-->
      </div><!--/.container-->
        <ul id="menu-main-menu-1" class="nav container-inner group"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16534"><a href="https://wptsradio.org/listen/">Listen</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-16529"><a href="https://wptsradio.org/about/">About</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16531"><a href="https://wptsradio.org/contact/staff/">Staff</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19744"><a href="https://wptsradio.org/showschedule/">Full Show Schedule</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16532"><a href="https://wptsradio.org/contacting-the-station/">Contacting the Station</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20991"><a href="https://wptsradio.org/about/mission-vision-values/">Mission, Vision, Values</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23569"><a href="https://wptsradio.org/get-involved/">Connect</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16537"><a href="https://wptsradio.org/dept/archives/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22206"><a href="https://wptsradio.org/dept/news-department/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16558"><a href="https://wptsradio.org/dept/sports/">Sports</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25324"><a href="https://wptsradio.org/dept/sports/pitt-60/">Pitt60</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25365"><a href="https://wptsradio.org/podcasts/">Podcasts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24490"><a href="https://wptsradio.org/dept/events/">Events</a></li>
</ul>  </div>
</nav><!--/#nav-header-->      
    </div><!--/.container-inner-->
      </div><!--/.container-->

</header><!--/#header-->
  
  <div class="container" id="page">
    <div class="container-inner">
            <div class="main">
        <div class="main-inner group">
          
              <section class="content">
              <div class="page-title pad group">
          	    		<ul class="meta-single group">
    			<li class="category"><a href="https://wptsradio.org/dept/general/" rel="category tag">General Station</a> <span>/</span> <a href="https://wptsradio.org/dept/archives/" rel="category tag">Music</a></li>
    			    		</ul>

    	
    </div><!--/.page-title-->
          <div class="pad group">
              <article class="post-25444 post type-post status-publish format-standard hentry category-general category-archives tag-beach-house tag-blood-orange tag-boy-pablo tag-boygenius tag-brockhampton tag-car-seat-headrest tag-caroline-rose tag-courtney-barnett tag-current-joys tag-denzel-curry tag-earl-sweatshirt tag-end-of-the-year tag-gobbinjr tag-guerilla-toss tag-homesafe tag-jack-stauber tag-janelle-monae tag-jid tag-jpegmafia tag-kali-uchis tag-kero-kero-bonito tag-lala-lala tag-lets-eat-grandma tag-list tag-liz-cooper-and-the-stampede tag-lucy-dacus tag-mac-miller tag-merce-lemon tag-mid-air-thief tag-mitski tag-mom-jeans tag-mourn tag-music-staff tag-noname tag-oh-sees tag-parquet-courts-2 tag-playboi-carti tag-pusha-t tag-rejjie-snow tag-rivers-of-nihil tag-saba tag-save-face tag-sidney-gish tag-snail-mail tag-soccer-mommy tag-sonder-bombs tag-spiritualized tag-the-punch-brothers tag-tierra-whack tag-top-albums tag-treble-nls tag-water-trash tag-young-fathers tag-yves-tumor">
    <div class="post-inner group">

      <h1 class="post-title entry-title">WPTS&#8217;s Top 50 Albums of 2018</h1>
<p class="post-byline">by   <span class="vcard author">
     <span class="fn"><a href="https://wptsradio.org/author/scales/" title="Posts by Scales" rel="author">Scales</a></span>
   </span> &middot;
                          Published <time class="published" datetime="December 31, 2018">December 31, 2018  </time>
               
          </p>
      
      <div class="clear"></div>

      <div class="entry themeform share">
        <div class="entry-inner">
          <p><!--2k18 AOTY orginized by Cauldar Burch MD and Scales
thanks to everyone who helped! --></p>
<p><em>As End of the year list season comes to a close, it&#8217;s time for WPTS&#8217;s 50 favorite albums. 2018 was a really exciting year for music, with a number of great releases across a number of styles. So, without further ado, here are WPTS&#8217;s highlights:</em></p>
<p><!--// template


//this one has lots of comments in it. read it so you know how it works. copy the entry below


<li><strong>Artist - album</strong>
[caption align="alignnone" width="300"]
<img src="" alt="" width="300" height="300"  />//set to height and width px 300 x 300
review//has to start on line above due to wordpress spacing quarks
<em>-Author</em>
[/caption]
</li>




//this one is for copy and pasting, it has less comments


<li><strong> - </strong>
[caption align="alignnone" width="300"]
image
review
<em>-Author</em>
[/caption]
</li>



--></p>
<ol reversed>
<li><strong> Caroline Rose &#8211; Loner </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/02/loner.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
When I first listened to Caroline Rose, I knew she was fire in a bottle. Her sophomore album, LONER, takes on a very different sound from her traditional Americana freshman album, and it goes without saying that she has found her niche. She combines synth pop with a wonderful voice and solid percussion to craft immersive songs. What adds even more is thoughtful and clever lyrics that offer critiques on the contemporary world. This album is easily in my personal top five of 2018. &#8220;Jeannie Becomes a Mom&#8221; has quickly become my favorite song and crafts a story that is applicable 100 times over. Rose is special, and the future is bright for her.<br />
&#8211; <a href="https://wptsradio.org/tag/chet-rengers/">Chet Rengers</a></em><br /></p></div>
</li>
<li><strong> Earl Sweatshirt &#8211; Some Rap Songs </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/earl_some-rap-songs-300x300.jpg"  " alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Earl Sweatshirt has followed an intriguing and rewarding path over the past eight years. Starting as a DOOM-worshipping wordsmith who reveled in foul language, imagery, and controversy, his music has turned inward as he&#8217;s grown older, now reflecting on his struggles with depression. He has grown increasingly abstract, his beat selection and verses turning lo-fi, muted, and tangled over the three years since his previous album, his various soundcloud singles, and Some Rap Songs. It would be a mistake to think that Earl no longer prizes wordplay; his knack for finding a perfectly phrased verse remains, but he&#8217;s also found meaning and purpose in delivering powerful truths with succinct and honest language. Some Rap Songs is an excellent showcase of his current talents. His low, barking verses lie buried in the midst of an pile of stuttering sample loops backed by strange, off-beat drum programming. In some cases, it&#8217;s even difficult to understand what he&#8217;s saying without looking up the lyrics elsewhere, which seems like a meditated response to those that appreciated his original, Eminem-style wordy appeal: a clue to, this time around, focus on both what he is saying and how he is saying it. This gamble, however, pays off in a big way, as the album&#8217;s desolate vibe, accompanied by Earl&#8217;s unsparing delivery and spare lyrics, stands as a stark exploration of depression, the fragility of one&#8217;s mental health, and in its final tracks &#8211; grief. Some Rap Songs, down to its deliberately unfitting, unassuming cover art and title is a rejection of Earl&#8217;s Odd Future days and a challenge to his fanbase, in the same manner as Frank Ocean&#8217;s Blonde. It&#8217;s an improvement and an evolution of the sound he began to embrace in 2015, and taking the time to sink into this album&#8217;s murky depths will prove why it has the power to stand as one of the greatest albums of this year.<br />
&#8211; <a href="TEMP">Nate Kovar</a></em><br /></p></div>
</li>
<li><strong> Young Fathers &#8211; Cocoa Sugar </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/YOUNG_FATHERS_PACKSHOT_RGB_3000X3000_small.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Cocoa Sugar was my first taste of Young Fathers &#8211; the Scottish trio of G Hastings, Kayus Bankole, and Alloyisious Massaquoi &#8211; and I’m glad I took the dive. This third full length from the band blends elements of trip hop, electronica, and world music, while maintaining a level of minimalism somewhere between Frank Ocean&#8217;s Blonde and Kanye West&#8217;s Yeezus. This backdrop allows the harmonic play between the three voices of the band to be the focus of Cocoa Sugar. The brooding synths bubbling in the background of almost every track here give Cocoa Sugar a dark tone that invites you to stay awhile, and it’s definitely worth looking around.<br />
&#8211; <a href="https://wptsradio.org/tag/nick-jacobyansky/">Nick Jacobyansky</a></em><br /></p></div>
</li>
<li><strong> Rivers of Nihil &#8211; Where Owls Know My Name </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/03/Rivers-of-Nihil.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Rivers of Nihil are the perfect example of what 2018 was for death metal. Where Owls Know My Name was an exercise in creativity and sheer brutality, as the band crafted layered songs that were able to balance chunky riffs with intricate interludes. On the title tracks and songs such as “The Silent Life,” the band seamlessly integrated saxophone into their sound, creating something fun and unique. Sonically, the band succeeded in creating an album that captures the essence of Fall and captivates from start to finish. I have been listening to this album since March and, regardless of the number of listens, it never gets stale. It’s a must listen for any fan of heavy music.<br />
&#8211; <a href="https://wptsradio.org/TAG/alex-cohen/">Alex Cohen</a></em><br /></p></div>
</li>
<li><strong> Janelle Monae &#8211; Dirty Computer </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/janelle.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Dirty Computer features synth-pop/pop-funk beats paired with Monae’s lush vocals which made it impossible for me to sit still while listening to this album. Janelle Monae uses contagious, bubbly melodies to celebrate her differences and her sexuality, as well as speak out against inequality in all forms. Dirty Computer is charged with emotion, addressing what it is like to feel different and marginalized due to race, gender, sexuality, etc. Monae embraces her differences, her body, and her sexuality, challenging the stigmas that currently surround female sexuality. Songs like &#8220;PYNK&#8221;, &#8220;I Like That&#8221;, and &#8220;Make Me Feel&#8221; invoke feelings of empowerment, and encourage people to embrace their own uniqueness rather than being ashamed of it. Monae encourages self-expression and self-acceptance, allowing herself to be vulnerable in order to encourage others to do the same.<br />
&#8211; <a href="TEMP">Sarah Worthington</a></em><br /></p></div>
</li>
<li><strong> OH SEES &#8211; Smote Reverser </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/OH-SEES.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Wowza.Oh Sees: the best live band to ever exist in the history of forever, especially with the recent inclusion of the keyboardist from Mr. Elevator, Tomas Dolas. Their LP Smote Reverser, released recently this year, is a great album composed of the best elements of Oh Sees material all blended together. You have the classic John Dwyer vocal delivery with some harmonies by Lady Brigid Dawson, succulent fuzz guitar leads with weird pedals, and a perfect dosage of psych-synth and prog/blues-organ. The drums and bass give a constant supply of great hypnotic rhythms to the psychedelic jams on many of the songs. One of the best albums from Oh Sees, Smote Reverser is a psychedelic/garage/heavy/prog rock masterpiece and the best in the genre that came out this year, in my opinion.<br />
&#8211; <a href="TEMP">Ocean</a></em><br /></p></div>
</li>
<li><strong> Brockhampton &#8211; iridescent </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/11/https_2F2Fimages.genius.com2F5da37b77be2204a52bd0433c6650f563.1000x1000x1.png"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
The first of six albums in BROCKHAMPTON&#8217;s 15 million dollar deal with RCA, as well as their first without Ameer Vaan, Iridescence is an artistic step forward for the world&#8217;s greatest boyband. Iridescence is a relaxed album as a whole; even its most punchy songs have a relaxed feeling to it. It&#8217;s a vibe. The group mainly performs over either futuristic and drone-like production on their rap-oriented songs but also use beautiful, orchestral-heavy production on songs like &#8220;WEIGHT&#8221; that help bring out the raw emotions in the lyrics from the boys. This departure from more typical hip-hop beats has allowed Joba and Merlyn to really shine, on songs such as &#8220;J&#8217;OUVERT&#8221; and &#8220;NEW ORLEANS.&#8221; Other great songs from this album include &#8220;HONEY&#8221; and &#8220;TONYA&#8221;, both of which showcase the amazing production on the album, the latter of which is my personal favorite track on the album.<br />
&#8211; <a href="TEMP">Zack Kaminski</a></em><br /></p></div>
</li>
<li><strong> Guerilla Toss &#8211; Twisted Crystal </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/Guerilla.jpg"  width="300" height="300"  /><p class="wp-caption-text"><br />
Like, woah. I feel like I’m stuck inside a circuit board of a really old arcade game, being zapped and sent from place to place listening to this album. Guerilla Toss takes one on a sonic adventure through a deserted desert highway at 3AM, speeding in a convertible. This album pumps you up and doesn’t really take you down, honestly, it’s so good. With the funkiest of bass lines and the smoothest high hats, Guerilla Toss incorporates so many different sounds: flutes in &#8220;Retreat,&#8221; synth in everything, chopped short vocals in &#8220;Come With Me,&#8221; looping melodies in &#8220;Walls of the Universe&#8221; &#8211; it’s just so good. Vaping Energizer Bunny vibes. It&#8217;s something good to put on when you just can’t get yourself out of bed or need motivation in general.<br />
&#8211; <a href="TEMP">Margie</a></em><br /></p></div>
</li>
<li><strong> Liz Cooper and the Stampede &#8211; Window Flowers </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/09/liz-cooper-window-flowers.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Who is Liz Cooper? She is a badass, enough said. But in all seriousness, psychedelic rock and Americana have never sounded better under Cooper and the Stampede’s craftsmanship. You want deep catchy bass lines that also make you feel emotions you haven’t felt in a while? Liz Cooper is for you. This is a three-instrument outfit (bass, drums, and guitar), and they make it sound like there are 12 of them. There are too many great songs to count off their freshman album Window Flowers and, honestly, I truly believe you could not go wrong with a single one. &#8220;Motions&#8221; and &#8220;Mountain Man&#8221; will make your day better, and I can’t wait to hear more from Liz!<br />
&#8211; <a href="https://wptsradio.org/tag/chet-rengers/">Chet Rengers</a></em><br /></p></div>
</li>
<li><strong> Homesafe &#8211; One </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/09/homesafe-one.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Homesafe&#8217;s sophomore LP has proven to be a force to be reckoned with in their scene. Drawing inspiration from bands like the Foo Fighters and Third Eye Blind, One sounds like the perfect marriage of 90s rock and new-age alternative pop punk. Pop-punk records have a tendency to be made up of songs that mostly sound the same, and One is an impressive departure from that, with tracks bringing listeners through a variety of emotions and beautifully conveying themes of personal growth, belonging, and understanding. Intricate and technical melodies married with relentlessly emotional vocals provide a sound that is innovative yet classical to the roots of the genre.<br />
&#8211; <a href="https://wptsradio.org/tag/bethany-brubeck/">Bethany Brubeck</a></em><br /></p></div>
</li>
<li><strong> Sonder Bombs &#8211; Modern Female Rockstar </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/modern_female_rockstar-300x300.png"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
The Sonder Bombs rule the world. Their uke-driven, high energy, deeply honest pop-punk will kick your ass, give you band-aids and a cup of hot cocoa, and kick your ass again. This year has been incredible for them, including the release of their first full length album on Take This to Heart Records, a tour along the east coast, and an intensely positive reception from fans and critics alike. Modern Female Rockstar is a letter of declaration to the scene, calling attention to the hypocrisy of many non-male participants in today’s DIY culture. On the track “Title,” vocalist Willow Hawks tells us: “I don’t wanna be your merch girl/I wanna be your goddamn idol.” This energy carries itself throughout the album, from fun tracks like “Atom” and “Shoot 2 Kill,” and exploding with danceable rhythm to “Twinkle Lights,” a song dedicated at each of their live performances to people dealing with mental health struggles and survivors of sexual assault. And this is indeed a deeply meaningful dedication, with Willow singing “There’s nothing really wrong with me/I’m just choking almost constantly/There’s nothing really wrong with me.” I’ve heard people say they feel indebted to a band before, but never personally understood what this meant. I am indebted to the Sonder Bombs. I could not have had the year I did without their music to lean on along the way. Take a listen &#8211; maybe they can help you too.<br />
&#8211; <a href="https://wptsradio.org/tag/dustin-butoryak/">Dustin Butoryak</a></em><br /></p></div>
</li>
<li><strong> Punch Brothers &#8211; All Ashore </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/punch.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
The Punch Brothers&#8217; album is the only Bluegrass album on our 2018 list. This album varies from their others as well as traditional bluegrass, as it&#8217;s quieter and sounds a lot more acoustic and simplified. That’s not to say that these songs are simple. You can tell that there are classical undertones in every song, and every note played sounds precise and planned out perfectly. At first the album seemed a bit boring as it was soft and straightforward, but the more you listen to it, it is anything but. My favorite songs include &#8220;Look at This Mess&#8221; and &#8220;Jumbo.&#8221; &#8220;Jumbo&#8221; is a bit more fast paced and catchy, and it focuses on some political discourse, but the instrumentation on it is beautiful. Put this one on your &#8220;listen to&#8221; list.<br />
&#8211; <a href="https://wptsradio.org/tag/chet-rengers/">Chet Rengers</a></em><br /></p></div>
</li>
<li><strong> Rejjie Snow &#8211; Dear Annie </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/dear.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
If Tyler the Creator and a leprachaun had a baby, I would be easily convinced that their child would not be far from someone like Rejjie Snow. His flow is impressively consistent throughout his entire debut album, Dear Annie: perfectly encapsulating pop-like RnB through twinkly, electric piano beats and catchy ad-libs. This consistency is quite refreshing and makes the entire album feel like one continuous dialogue of music as he takes you on a lyrical odyssey through the highs and lows of love. I would say that many of his songs, including &#8220;The Rain,&#8221; &#8220;Oh No!,&#8221; and &#8220;Charlie Brown&#8221; would be even better accompanied in a field, while basking in sunlight. Trust me when I say it would immediately bring you pure bliss. The pop-like structure of each song makes Dear Annie the perfect album for those that love rap with an upbeat framework.<br />
&#8211; <a href="TEMP">Ace Koh</a></em><br /></p></div>
</li>
<li><strong> Water Trash &#8211; No Dice </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/no-dice.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Delivering good tunes from start to finish, No Dice is a wonderfully dynamic album that contains some real treasures. All of the members of this local band contribute to an album that is thoroughly entertaining. Starting off with a bang, the title song &#8220;No Dice&#8221;, leads you into the album with a youthful energy. The album that follows contains a variety of entertaining hits with highlights including &#8220;Kill Boredom&#8221; and &#8220;Fine&#8221;. Listening to this album with a friend, we found it hard to find a song in this mix that is lackluster as all the songs bring their own flare. The band is a treat to the ears, wonderful live and just as wonderful in their recording of No Dice.<br />
&#8211; <a href="TEMP">Malcolm</a></em><br /></p></div>
</li>
<li><strong> Mom Jeans &#8211; Puppy Love </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/mom-jeans.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
While Mom Jeans clearly displays their sense of humor through their wacky song titles and their goofy quotes and descriptions, they also display their roots through Puppy Love. These ten songs are only half an hour long together, but they are well written and honest. Mom Jeans is fast and upbeat, very engaging stylistically &#8211; great for driving music or just when you need to clear your head.<br />
&#8211; <a href="TEMP">Samuel Taylor</a></em><br /></p></div>
</li>
<li><strong> Spiritualized &#8211; And Nothing Hurt </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/Spirtualized_And-Nothing-Hurt.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Spiritualized never ceases to amaze me. 20 years after releasing his classic Ladies and Gentleman We are Floating in Space, Jay Spaceman still has it. During the recording of this album, he found himself in a tough spot paying for hospital bills since his dance with death a few years ago. This lack of funds did not allow him to get studio time or the normal orchestras that are present on past Spiritualized albums. But those sounds are still present on this album, and thats due to Pro Tools. Yes, most of this album was made with Pro Tools in his own home. Stiching together orchestral samples along with his own guitar and percussion work, Jay has made what may be his most impressive Spiritualized album yet. These songs are still classic Spiritualized songs with grand crescendos and instrumental cacophany about love and loss. Since Jay claims he is retiring, this may be it for Spiritualized, but I can say without a doubt that And Nothing Hurt was a great way to end a legendary career.<br />
&#8211; <a href="https://wptsradio.org/tag/dylan-falk/">Dylan Falk</a></em><br /></p></div>
</li>
<li><strong> Mid-Air Thief &#8211; Crumbling </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/mid-air-thief.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
The forty-four-minute debut EP of South Korean group Mid-Air Thief is a stunning work of electro-folk tethered by no generic conventions whatsoever. Crumbling takes cues from Cornelius-esque electronica and the ethereal free-folk of New Weird America to create something organic, unique, and mystifying. The swirling coos, ‘far-out’ synths, and reverberating found-sounds swirl to a three-dimensional effect that feels, to me, like some sort of immaculate cleansing experience rather than an album. Crumbling pays homage to Korean psychedelic greats (namely Shin Jung-hyeon) not sonically, but via the carefree spirit and love of music clear throughout.<br />
&#8211; <a href="https://wptsradio.org/tag/spencer-smith/">Spencer</a></em><br /></p></div>
</li>
<li><strong> Boy Pablo &#8211; Soy Pablo </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/11/BoyPabloCover.jpeg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
I first discovered Boy Pablo’s music when I was invited to their concert in Boston. Their music is full of energy, and their second EP, Soy Pablo, does a good job of keeping that energy. Songs such as &#8220;Feeling Lonely&#8221; are a perfect example of why I enjoy their music. It’s a song about a presumably sad topic; however, the instruments drive an upbeat and energetic vibe into the song. While the lyrics are sad, the song itself makes you want to get up and jump around. No matter what the song is about, Boy Pablo never ceases to make me want to dance all day. This album was one of the most fun albums I listened to all year, and I love listening to the upbeat guitar solos whenever I’m in a dancing mood.<br />
&#8211; <a href="https://wptsradio.org/TAG/daniel-tobin/">Daniel Tobin</a></em><br /></p></div>
</li>
<li><strong> Yves Tumor &#8211; Safe In The Hands of Love </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/safeinthehands.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Yves Tumor’s brand of experimental music is quite hard to pinpoint, at least judging from the scatterbrained Safe In The Hands of Love. In one breath, Yves Tumor is crafting sleek pop music, and in the next they’re delivering a flurry of cacophony, and sometimes even on the same track! The highly eclectic nature of Safe is extremely disorienting while somehow tying the record together, and that aligns so well with its M.O.: tracks like “Noid,” the electro-pop anthem for the paranoid world of 2018, and closer “Let the Lioness In You Flow Freely,” an industrial barrage of chaotic drumming, have the same terrifying effect on me, as different as they are. The latter has an ending like a Black Mirror episode without the closure; an unrelated 80s pop song is sampled to abruptly close the album, which really has a mind blowing effect. As mind boggling as this album is, there are so many cool ideas explored and executed well that it’s so enticing to come back to make sense of its frightening, hectic world.<br />
&#8211; <a href="https://wptsradio.org/tag/nick-jacobyansky/">Nick Jacobyansky</a></em><br /></p></div>
</li>
<li><strong> Tierra Whack &#8211; Whack World </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/Tierra-Whack_Whack-World-EP.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
15 songs in 15 minutes? That’s Tierra Wack for you. Despite the brevity of each song, Whack delivers her debut album as an eclectic masterpiece. A Philadelphia native, Whack proves herself as an individual in the RnB community as she releases songs like &#8220;F*ck Off&#8221; that oddly reminds me of that Old McDonald hymn that&#8217;s usually sung to children. However, she manages to transform the tune into a funky, cool RnB interpretation making me question where the limits of RnB can go; it’s comedic, colorful, and showcases a stream of consciousness that is honest, yet ironic. In her song Pet Cemetery, Whack sings about the heartbreak of losing her dog, which can also be interpreted as her “dawg.” In &#8220;Fruit Salad,&#8221; she simply tells you to eat more fruits and veggies. Whack World makes you feel good in all ways, and I would suggest anyone to check out the music video that showcases the visual surrealism of each song in one video. In a nutshell, what I got out of this album is summed up as “Tic-Tac-toe, Mario, Dominoes, and Uno. If you play your cards right, it’ll be alright”.<br />
&#8211; <a href="TEMP">Ace Koh</a></em><br /></p></div>
</li>
<li><strong> Car Seat Headrest &#8211; Twin Fantasy (Face to Face) </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/03/Car-Seat-Headrest.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Oh Will Teledo, you crazy man. One of the brightest stars and loudest voices in indie rock today has rerecorded his lo-fi bandcamp classic. So why did a re-record make our top 50 end of year list here at WPTS? Because it is nearly a new album in its entireity. This album&#8217;s lyrics have evolved along with Toledo&#8217;s growth as a person. Each song presents a new meaning as a man in his mid twenties breaking onto the indie scene versus an unknown teenager recording in his garage. I also believe the sonic evolution in this album has really made these songs pop. &#8220;Cute Thing&#8221; and &#8220;Bodys&#8221; are indie rock at its finest and sound great without the lo-fi bedroom recording presented in the original. Long, drawn-out, and wordy songs such as &#8220;Beach Life In Death&#8221; have become easier to listen to, and the lyrics have been put at the forefront of these songs. Twin Fantasy (Face to Face) is an example of how art can change through time and presentation, and this new update is fantastic, emotional, and, man, does it rock.<br />
&#8211; <a href="https://wptsradio.org/tag/dylan-falk/">dylan falk</a></em><br /></p></div>
</li>
<li><strong> Treble NLS &#8211; Reine: Story of an American Reject </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/a32cd99ccc7ef74ab3e82d30e8b8389a.1000x1000x1.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
“What beautiful sounds,” croons Treble NLS in the opening moments of his debut record. Honestly, I couldn’t have said it better myself. I heard Shyheim Banks’ music earlier this year at a basement show here in Pittsburgh, and watching his rise to underground acclaim this year has been nothing short of thrilling. Reine is equal parts bitter, voyeuristic, and deeply longing. This album keeps effortless pace with the unbelievably great hip-hop 2018 has delivered, exploring the heart of someone suffering the pain of an unrequited love. Treble nails this tone impeccably. On “Chemistry” he sings, “Life can be a box of chocolates/or a box of toxic people/looking for a lock with every combination possible”. On “Signs”, he sings, “What’s behind your eyes?/Let’s explore your mind./What’s behind your skies?/Take me for a ride./Twinkle Twinkle but no star/I think I saw a sign.” Bars like these are interspersed throughout the album, making for an engaging and deeply thought provoking listen. As Treble NLS says at his shows, “Never Lose Sight” of this album.<br />
&#8211; <a href="https://wptsradio.org/tag/dustin-butoryak/">Dustin Butoryak</a></em><br /></p></div>
</li>
<li><strong> Playboi Carti &#8211; Die Lit </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/die-lit-playboi-carti-hi-res-cover.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Die Lit is the purest expression of Playboi Carti’s sound, and the best album to have come out of the ‘mumble rap’ scene to date. Verses start and stop without warning, buried under mountains of layered ad-libs (approaching the level of shoegaze riffs) and hazy production from Pi’erre Bourne and others. Carti’s vocal delivery has warped into a strange, cartoony falsetto, matching its soundscape perfectly. The true strength here is Carti’s laid-back, off-kilter vibe, which he has fully mastered. Free from the pressure to construct coherent lyrics and tinker with clever wordplay, he makes increasingly bold song structure and beat choices, content to warp his words in whatever way suits the track, rather than the other way around. This puts this album in its own class simply in how it breaks free from rap conventions in every possible way &#8211; all without seeming like he’s trying at all.<br />
&#8211; <a href="TEMP">Nate Kovar</a></em><br /></p></div>
</li>
<li><strong> Save Face &#8211; Merci </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/sfm.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Save Face&#8217;s debut alubm, Merci, left it&#8217;s mark amongst all of the releases of 2018 with a huge and unique presence. This fourteen track concept album with music videos acompanying each song certainly stands apart from other albums in the pop-punk/post-hardcore scene, as it cleverly utilizes catchy hooks and riffs to drive home its lyrical messages of love and loss without falling into cliche tropes or a repetative sound from song to song. The high energy of the album as a whole perfectly encapsulates the portrayal of the characters in the story it tells, and does so very artistically. Combining dynamic percussion, in-your-face crunchy guitar riffs, and very visually specific lyrics results in this ambitious yet groundbreaking LP that tells a story so honest the listener can&#8217;t help but be captivated.<br />
&#8211; <a href="https://wptsradio.org/tag/bethany-brubeck/">Bethany Brubeck</a></em><br /></p></div>
</li>
<li><strong> Mourn &#8211; Sorpresa Familia </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/mourn.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
This past year Barcelona Indie Post-Punkers Mourn delivered their stand out third album, Sorpresa Familia. An anxiety inducing romp in the best way, their Captured Tracks debut combines angular guitars and a tight complex rhythm section to set a backdrop over which the two vocalists sing passionate, multilingual vocals. Poetic lyrics paint vivid pictures over the urgent punk infused backdrops. The album starts strong with &#8220;Barcelona City Tours,&#8221; bringing an energy that they manage to sustain throughout almost the entirety of the album. Their lyrical wit and knack for songwriting are illustrated on Indie Rock diss track &#8220;Fun at the Geysers.&#8221; Overall, Sorpresa Familia is an exciting release that proves that Mourn is a band to watch.<br />
&#8211; <a href="https://wptsradio.org/tag/calder-buisch/">Calder Buisch</a></em><br /></p></div>
</li>
<li><strong> Denzel Curry &#8211; TA1300 </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/denz.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
TA13OO and Denzel Curry as a whole are not my normal cup of tea. As someone who spends most of his time listening to quieter indie, RnB, and electronic music, a rap album that goes as hard as this one nornally does not appeal to me. But if this wasn&#8217;t the sound of my summer, I don&#8217;t know what would have been. This album consists of three parts that were released over three nights in July of this year: Light, Gray, and Dark. The first part, Light, is full of songs with catchy RnB riffs, with Denzell&#8217;s rapping somewhat reserved, but he shows his true self at the end of this song with&#8221;SUMO&#8221; one of the most quotable songs of the year. The second part, Gray, begins to get darker and harder with each track ending on &#8220;CLOUT COBAIN:&#8221; a view into the societal pressures people put on artists and how depression is viewed by fans and the press. The final part, Dark, has four insane tracks. Each one of these songs could be the heaviest rap song of the year, my favorite being &#8220;VENGEANCE&#8221; featuring JPEGMAFIA and Zillakami. All three parts together feel like 45 minute long mosh pit. I am not sure why I love this album so much, but I do know it needs to be played loud and it needs to be played everywhere.<br />
&#8211; <a href="https://wptsradio.org/tag/dylan-falk/">Dylan Falk</a></em><br /></p></div>
</li>
<li><strong> Let&#8217;s Eat Grandma &#8211; I&#8217;m All Ears </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/07/LetsEatGrandamaImAllEars.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
I have been absolutely floored by I’m All Ears, the sophomore effort from UK duo Let’s Eat Grandma, since hearing it in July. This varied synth pop tour de force blends elements of EDM, indie rock, and shoegaze to make for some highly textured, densely layered, and dynamic instrumentals. The expertly executed builds and changeups on cuts like “I Will Be Waiting” and “Falling Into Me” are bone chilling time and time again. These emotional musical moments, coupled with the unified voices of Rosa Walton and Jenny Hollingsworth, lend the album a certain youthful seriousness that gives weight to its personal lyrics. I cannot stop listening to this piece of pop perfection, and am extremely excited about what the duo of 19-year-olds will do next.</p>
<p>&#8211; <a href="https://wptsradio.org/tag/nick-jacobyansky/">Nick Jacobyansky</a></em><br /></p></div>
</li>
<li><strong> Kero Kero Bonito &#8211; Time ‘n’ Place </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/kkb.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Kero Kero Bonito’s triumphant sophomore LP takes the melodic prowess and bubblegum pop of Bonito Generation and applies it to a traditional rock pallette. The band continues to work with their trademark bubbly electronic production, supplemented with their newfound knack for noise and power pop arrangements. Even former doubters of the group’s infectious K-pop hybrid are bound to double-take at the undeniable skill and wit packed into Time ‘n’ Place’s instrumentation. What makes KKB special is how playful producers Gus and Jamie are willing to be, as well as Sarah Bonito’s earnest, simple lyrics that somehow deliver the human condition in the form of a big ball of sunshine.<br />
&#8211; <a href="https://wptsradio.org/tag/spencer-smith/">Spencer Smith</a></em><br /></p></div>
</li>
<li><strong> boygenius &#8211; boygenius </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/boygeniusAlbumCover.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
What can I say about Boygenius that hasn&#8217;t already been said. This supergroup, consisting of Julien Baker, Lucy Dacus, and Phoebe Bridgers, created one of the most universally lauded pieces of music in indie this year. It deserves everything that has been said about it. You would think that putting three fantastic songwriters together might clog the drain, but no, they just build off of each other&#8217;s skills. These six songs would find there way at the top of my favorites of each of these artists, and I have enjoyed them each individually on prior albums. While these songs are sad, they are also resotrative, powerful, and simply awe inspiring. I expect to be using these songs to heal myself in times of hardship for years to come, and hope to hear from these three again in the near future.<br />
&#8211; <a href="https://wptsradio.org/tag/dylan-falk/">Dylan Falk</a></em><br /></p></div>
</li>
<li><strong> Saba &#8211; CARE FOR ME </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/Saba_-Care-For-Me.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
One of the brightest rap talents in the world, Chicago born rapper SABA has had quite a year. In addition to releasing new music virtually every week in November and December, he released his second studio album to stunning underground acclaim. CARE FOR ME is interwoven with muted greys, blacks, and whites, and serves as a devastating portrait of a racing mind unable to move fast enough to cope with the loss of a loved one. Deeply introspective and intensely honest, SABA pulls no punches in sifting through the shattered fragments of his life following the murder of his friend John Walt. The album has been hailed by many as a glimpse into a therapy session with SABA, and, while this is valid, I would argue he delves deeper than this. CARE FOR ME is SABA’s mind hung on a pedestal for the world to marvel at &#8211; he bares his soul on everything from toxic relationships, the overwhelming weight of survivor’s guilt, and ultimately how he continued to keep on living past such an incredible loss. Each track is laden with raw prose detailing his experiences, such as in “CALLIGRAPHY” when he sings “I&#8217;m not mad at God, I just can&#8217;t get out of bed/My best friend obituary really hang on my wall, by the dresser/I&#8217;m tryna see it, a life lesson.” This uninhibited emotion packed snugly between flourishes of brass and jazz fueled production deliver the unsettling, deeply mournful tone present beneath the entire album. This is not an uplifting listen, but it is an incredibly important one. If you check out another album this year, make it this one.<br />
&#8211; <a href="https://wptsradio.org/tag/dustin-butoryak/">Dustin Butoryak</a></em><br /></p></div>
</li>
<li><strong> Courtney Barnett &#8211; Tell Me How You Really Feel </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/Tell-Me-How-You-Really-Feel.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
With her second full length, Barnett expands her form with more relaxing soundscapes. The album adds a sense of forgiveness, understanding and, a reminder to be yourself. That’s not to say she lost what made her debut special. There are still grunge tinged bangers that I screamed along with throughout my work filled summer. Barnett is only two albums into her career but presents the kind of growth and has left an impact that other artists with more than a dozen albums haven’t come close to. I remember when the first single for this was reviewed on WPTS Recommends early this year, someone on the panel was surprised at the refrain ‘Men are afraid that women will laugh at them. Women are afraid that men will kill them. At the time it seemed bold but after our first full year in a post “#metoo”era, it may be exactly what we needed.<br />
&#8211; <a href="https://wptsradio.org/tag/scales/">Scales</a></em><br /></p></div>
</li>
<li><strong> Gobbinjr &#8211; Ocala Wick </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/gob.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Gobbinjr writes clever depressing pop songs. Ocala Wick is an album that is frustrated by humanity and filled with discomfort. She conveys this in two ways: through her lyrics and the layering of sounds she chooses to use. For example, on the song &#8220;Fake Bitch,&#8221; Emma Witner opens with the poignant lyric “You pressed your dick against my thigh,” making the audience experience her own discomfort which is emphasized by the lack layering in this moment to understand the tone of her voice, which is frustrated. Ocala Wick is a very layered pop album that has a very distinct sound. As the year went on, this album became one of my favorite of the year due to it&#8217;s catchiness and how much time has clearly been put into every song. </p>
<p>&#8211; <a href="https://wptsradio.org/tag/elyssa-pollio/">Elyssa Pollio</a></em><br /></p></div>
</li>
<li><strong> Snail Mail &#8211; Lush </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/07/snail-mail-album-cover.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Snail Mail shot onto the scene with her debut album Lush. She had previously had success with her EP Habit, but her first album exploded her into one of the biggest new artists in the indie scene. What I think helps her stand out from other indie artists of similar style is her guitar. I personally find the guitar in her songs to be a perfect fit, and I think it beautifully compliments her singing. A great example of her guitar work is the song &#8220;Heat Wave.&#8221; While it isn’t anything crazy, it’s very effective. Snail Mail quickly rose to fame and if she keeps it up then she’ll be here to stay for a while.</p>
<p>&#8211; <a href="https://wptsradio.org/TAG/daniel-tobin/">Daniel Tobin</a></em><br /></p></div>
</li>
<li><strong> Kali Uchis &#8211; Isolation </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/kali.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Isolation by Kali Uchis is fifteen solid tracks. It’s as simple as that. But it makes me wonder, what’s the secret? How do these fifteen tracks continue to hold up in one of the most competitive Albums of the Year lists WPTS has seen? I think the difference is that Kali Uchis’s personality makes this whole album pop. Her witty lyrics and compelling storytelling cover a full range of emotions, but in a refreshing, and sometimes snarky way. And of course, this all sits atop an instrumental foundation that is on lockdown. Kali&#8217;s brilliantly catchy ideas work seamlessly with input from amazing musical minds like Thundercat, Steve Lacy, Bootsy Collins, Jorja Smith, and more, all while still feeling uniquely her own. A badass first LP for Kali, and I&#8217;m glad to say, a badass addition to our WPTS Albums of the Year list.<br />
&#8211; <a href="https://wptsradio.org/tag/sam-taylor/">Sam Taylor</a></em><br /></p></div>
</li>
<li><strong> Merce Lemon &#8211; Girls Who Jump In </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/07/GirlsWhoJumpIn.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Local queer sea creature Merce Lemon stretched a new, folky muscle on their May release Girls Who Jump In. Equal parts playful and soothing, listening to Merce’s music is like floating down a lukewarm lazy river with your best friend. Despite its relaxing energy, Merce isn’t afraid to deliver incredibly poignant, honest thoughts on life, love, and (occasionally) menstruation. On “Spill it Out” they deliver the tongue in cheek lyric “I barely know how to play guitar so I’ll just play the same chords I did in the last song./Same strum pattern over and over I’m giving away all of my secrets.” Merce isn&#8217;t afraid to openly discuss more taboo topics on multiple tracks, including “Remedies” with Merce singing “I’ll be your human drum/drum on me until I’m numb/I’ll be your diva cup/catch up all your blood, all of your blood.” Put simply, Girls is just a complete joy to listen to, from start to finish. Do yourself a favor and check it out.<br />
&#8211; <a href="https://wptsradio.org/tag/dustin-butoryak/">Dustin Butoryak</a></em><br /></p></div>
</li>
<li><strong> Lucy Dacus &#8211; Historian </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/03/Lucy-Dacus.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
The first time I heard Lucy Dacus’ second album Historian, it was the Friday before spring break while I was on the bus heading back to a hometown that I am not from &#8211; basically just a place where my parents live. A huge windstorm was hitting the east coast and I was worried I was going to have to sleep in Grand Central Station because the bus wouldn&#8217;t make it there on time for me to take a train. This was the perfect album for me at that point in time. Everytime I&#8217;ve listened to this album I&#8217;ve realized that it’s just a perfect album for 2018. Historian is, for the most part, an album about death and, for me, that’s what 2018 felt like: heavy but optimistic. </p>
<p>&#8211; <a href="https://wptsradio.org/tag/elyssa-pollio/">Elyssa Pollio</a></em><br /></p></div>
</li>
<li><strong> Soccer Mommy &#8211; Clean </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/03/Soccer-Mommy.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Soccer Mommy’s album Clean was widely appreciated this year in the indie scene. &#8220;Your Dog,&#8221; was a big hit and helped drive Soccer Mommy&#8217;s music to a broader audience of listeners. The variety of songs here is what makes the album great. You can get anything from an upbeat song such as &#8220;Clean,&#8221; to a beautifully written acoustic piece from &#8220;Scorpio Rising.&#8221; The instrumentals pull the listener in and the emotional lyrics get them invested the song. The emotions of the song are portrayed perfectly with the instrumentals as well as vocals. This album quickly became one of my favorites of the year and I have been listening to it since.<br />
&#8211; <a href="https://wptsradio.org/TAG/daniel-tobin/">Daniel Tobin</a></em><br /></p></div>
</li>
<li><strong> Pusha T &#8211; Daytona </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/07/Daytona.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Okay, show of hands, who among us looked at G.O.O.D. Music&#8217;s packed summer slate and thought: &#8220;yeah, that Pusha T album will probably be the best one.&#8221; No you didn&#8217;t, don&#8217;t lie to me, put your hand down. DAYTONA is, in this critic&#8217;s humble opinion, the best of the &#8220;short album&#8221; trend that took over hip hop in 2018. The album&#8217;s bite-sized length turns King Push&#8217;s one dimensional subject matter (partying and selling cocaine) into an asset rather than a limitation. DAYTONA serves as a lesson to all artists who&#8217;ve seen their prestige decline in recent years; you don&#8217;t necessarily have to reinvent yourself to reassert yourself.<br />
&#8211; <a href="https://wptsradio.org/tag/john-wright/">John Wright</a></em><br /></p></div>
</li>
<li><strong> Sidney Gish &#8211; No Dogs Allowed </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/03/sidney-gish-no-dogs-allowed.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
I discovered Sidney Gish’s No Dogs Allowed on January 9th of this year, shortly after its New Year’s Eve release. I listened to it with no expectations and was blown away. Sidney Gish is in the same age range as many of us here at WPTS, and her lyricism cuts through commonly shared emotions and experiences of young, insecure achievers—like many college students—by expertly flowing between moments of nonchalant self-deprecation, empowering clarity, and uninhibited fun and humor. This was one of my favorite albums of 2018, and over the course of a long year of devoted listening, Sidney Gish’s meticulous sophomore LP has cemented itself as one of my personal favorite albums of all time.<br />
&#8211; <a href="https://wptsradio.org/tag/sam-taylor/">Sam Taylor</a></em><br /></p></div>
</li>
<li><strong> Current Joys &#8211; A Different Age </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/03/current-joys.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
A Different Age by Current Joys is where I see Nick Rattigan explore the depths of who he is as a person. That sounds super cheesy, but it&#8217;s the truth. Throughout this whole album, we see themes of him learning, growing, and experimenting with his sound in terms of what else he can be other than his first project, Surf Curse &#8211; which is fast and hard &#8211; and instead finding different hills and valleys There&#8217;s also a distinct difference in subject matter, with lyrics connecting to his audience through feelings that everyone has but doesn’t really talk about. Listening to this album is just the tip of the iceberg, too, a first listen should really come with the visual album aspect. Sitting through that whole thing takes an emotional toll that will leave you feeling both hollow and content &#8211; a weird feeling to have. I find this feeling particularly in the tunes of &#8220;Alabama,&#8221; &#8220;In a Year of 13 Moons,&#8221; and &#8220;Fox.&#8221; These hauntingly beautiful indie songs will make your heart feel heavy and sometimes that’s just what the doctor ordered. In that case, this doctor is Nick Rattigan. This album is overall mellow and tranquil, melancholy and acoustic; except when it’s not, it’s really not. This being in Fear and the song the album is named after, A Different Age, where we feel his raw anger, confusion, and “Fear.” Listening to this album through is a trip, if you want to feel like a caterpillar who gets encased in its cocoon and then fights its way out, i.e. gooey (in the heart) but strong, give it a go.<br />
&#8211; <a href="I dont have one :''(">Margieee</a></em><br /></p></div>
</li>
<li><strong> Jack Stauber &#8211; HiLo </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/hilo.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
HiLo is Jack Stauber’s newest round of experimentation, and I sometimes can’t tell whether I’m a witness or a guinea pig. Every lyric and sound feels like a response to some viscerally held thought or emotion, which is intensely relatable, but in a freaky way. Themes of love and boredom and discomfort are brought to the surface from Jack’s id, yet overtop catchy, fun beats and soothing synth sounds. This juxtaposition of sweet and fun foundations plus Stauber’s particular brand of weirdness results in some of 2018’s most cathartic musical moments, like the chorus to “Dead Weight,” or when “Pad Thai” starts to go all insane.<br />
&#8211; <a href="https://wptsradio.org/tag/sam-taylor/">Sam Taylor</a></em><br /></p></div>
</li>
<li><strong> JID &#8211; DiCaprio 2 </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/jid.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
JID is a lyrical savant that may be without equal in modern hip hop. Every time &#8211; and there have been many such times recently &#8211; I decide to queue up DiCaprio 2 for a listen, I find a new bit of wordplay I&#8217;m impressed by, a new reference I understand, a new joke I didn&#8217;t know I was in on. JID&#8217;s flow is dense and variable in it&#8217;s voice and pace but packed full of meaning. After starting his year stuffed behind Trippie Redd, Ski Mask the Slump God, and Lil Pump in the 2018 XXL Freshman class, JID has proved his technical superiority to all these MCs, and he has asserted himself as one of the most potent weapons in Dreamville&#8217;s growing arsenal.<br />
&#8211; <a href="https://wptsradio.org/tag/john-wright/">John Wright</a></em><br /></p></div>
</li>
<li><strong> Blood Orange &#8211; Negro Swan </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/09/blood-orange_negro-swan.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Blood Orange’s latest album, Negro Swan, demonstrates sensual, psychedelic RnB with a beautifully artful and unique rendition of 80’s dance-pop. In his most painstakingly honest album to date, Devonte Hynes does not hold back on his innermost feelings of rejection as he explores black depression and the persistent struggles of queer/people of color. Dreamy vocals and textured jazz beats are the ultimate vessels for Hyne’s haunting narrative as he touches upon sensitive, tragic stories of various childhood traumas. Hynes works with transgender activist, Janet Mock, who features in multiple spoken word verses highlighting the realities of growing up different, confused, and out of place. Despite the melancholic themes, Negro Swan ultimately preaches upon the importance of staying true to who you are and finding self-empowerment through songs such as &#8220;Charcoal Baby&#8221; and &#8220;Jewelry&#8221;, whose verses celebrate black skin and encourage self-expression. This album is a daydream and a nightmare all at once, and I have appreciated Blood Orange’s masterful artistry more than ever since the release of Negro Swan.<br />
&#8211; <a href="TEMP">Ace Koh</a></em><br /></p></div>
</li>
<li><strong> Lala Lala &#8211; The Lamb </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/lala-lala_the-lamb.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
With move to dreamy post punk, Lala Lala is a front runner for most improved artist of the year. This is fitting as The Lamb details the improvements the artist has gone through since her last release. After her debut album, Lillie West gave up vices like drugs, alcohol, and sex. Without these, one might expect things to be peachy for her, but instead she shows a new vulnerable, more understanding side. Beneath the lyrics are layers of visceral and everchanging energy that provide the meaning where words would only be inadequate.<br />
&#8211; <a href="https://wptsradio.org/tag/scales/">Scales</a></em><br /></p></div>
</li>
<li><strong> JPEGMAFIA &#8211; Veteran </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/jpeg.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
If JPEGMAFIA thinks he can just stride in here with his agressive, abrasive hip hop sound making video game and wrestling references and win my heart, he is 100% correct. Veteran is an album I&#8217;ve come back to again and again since it&#8217;s release way back in January; whether for Peggy&#8217;s wry nerd wit and humor, or his unchained energy and anger on the mic. &#8220;The guy who just doesn&#8217;t give a damn&#8221; is a persona in hip hop that&#8217;s common to the point of being cliche, but on Veteran it feels genuine. JPEGMAFIA is saying whatever he wants to say, and I for one am paying close attention. All I can say in response is &#8220;daaaamn, Peggy.&#8221;<br />
&#8211; <a href="https://wptsradio.org/tag/john-wright/">John Wright</a></em><br /></p></div>
</li>
<li><strong> Parquet Courts &#8211; Wide Awake! </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/05/Parquet-Courts.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Every time you think Parquet Courts have hit something resembling a ceiling, they find a way to go past it. After doubling down on art rock with 2016&#8217;s Human Performance, the Savage brothers and co. have come roaring back with an energetic, danceable potpourri of an album that wears its influences on its sleeve but still manages to find an identity all its own. Wide Awake&#8217;s more subtle approach to the rage-inducing politics of our time does so much more for me than the endless parade of melodramatic wannabee protest songs that have come out since the 2016 election. Unquestionably my favorite album of 2018.<br />
&#8211; <a href="https://wptsradio.org/tag/john-wright/">John Wright</a></em><br /></p></div>
</li>
<li><strong> Beach House &#8211; 7 </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/05/BeachHouse7.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Beach House has evolved. 7 is a culmination of all their prior albums, with a new mix of heavier and darker productions. Over the past year, this album has become my favorite Beach House release, and is by far their most interesting to listen to. I first listened to this album in the dead of night on a plane miles high in the sky. Moments like the tranistion from &#8220;Dark Spring&#8221; to &#8220;Pay No Mind,&#8221; the crescendo throughout &#8220;Last Ride,&#8221; or thr second half of &#8220;Dive&#8221; blew me away then and still blow me away now. Beach House killed it with this album and have truly created musical bliss.<br />
&#8211; <a href="https://wptsradio.org/tag/dylan-falk/">Dylan Falk</a></em><br /></p></div>
</li>
<li><strong> Mac Miller &#8211; Swimming </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/12/Mac-Miller_Swimming.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
As the final and most bittersweet release of his career, Swimming guides the listener through Pittsburgh-born rapper Mac Miller’s inner battle with rising above addiction. Several weeks after releasing this album Mac died suddenly of a tragic overdose. This shocked the Pittsburgh community and the music world. Swimming is transient and imbued with funk, containing production help from legendary artist Thundercat among many others. The sprawling blues and whites in the album flow together like a clear blue sky, or possibly an ocean as Mac references multiple times in the record. Indeed, this is an ocean of an album. As intimate and intricate as Swimming is in exploring his inner conflicts, Mac never misses a chance to bring his struggles into a larger frame of reference. In “Small Worlds” he sings, “The world is so small/til it ain’t./I’m building up a wall/til’ it breaks.” The intermingling of nostalgia and regret is unlike anything I’ve heard before and left me with a broken heart left beating to the rhythm of Mac’s brilliance. The most heartwarming (and heartbreaking) facet of the album for me is Mac’s unwavering positivity of what the future holds. He begins the album by singing “Grey skies and I’m drifting/not living forever/They told me it only gets better”, and ending the album with the lyric “and I know I been out/but now I’m back in town/so I show you the ropes/so it goes.” The theme of circular experiences in Mac’s life bleeds through the album &#8211; love and loss, recovery and relapse, life and death &#8211; while imploring the listener (and possibly himself) to keep swimming. The loss of Mac Miller is undoubtedly a tragedy, especially here in Pittsburgh, however, we are extremely fortunate to have been left with such an incredible final work. RIP Mac- you will be missed dearly.<br />
&#8211; <a href="https://wptsradio.org/tag/dustin-butoryak/">Dustin Butoryak</a></em><br /></p></div>
</li>
<li><strong> Mitski &#8211; Be The Cowboy </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/08/be-the-cowboy.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
Mitski&#8217;s Be The Cowboy is a work of art that is receiving tons of deserved critical acclaim. Mitski really showcases her talent throughout this album, with a variety of sounds that all seem to fit perfectly together. The sounds on this album are so quirky. Mitski music has always blurred the lines between genres, but in this album, I really feel like she went all in. It feels like this album is all Mitski, no one is making her stick to a theme, it’s just her. On top of all of that, the album repeats the word “nobody” multiple times, to stick to the themes of being alone and a lonesome cowboy. This is what makes it one of the most interesting and amazing albums of the year.<br />
&#8211; <a href="https://wptsradio.org/tag/elyssa-pollio/">Elyssa Pollio</a></em><br /></p></div>
</li>
<li><strong> Noname &#8211; Room 25 </strong><br />
<div style="width: 310px" class="wp-caption alignnone"><img   src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/09/noname-room-25.jpg"  alt="" width="300" height="300"  /><p class="wp-caption-text"><br />
At the base of Noname’s (AKA Fatimah Nyeema Warner) music is her love of poetry. Room 25 is a bit of a jump from her last project, Telefone, though it&#8217;s still bursting with candid and inventive flow. This new album marks a sort of coming of age for Warner as it chronicles her move from her hometown of Chicago to Los Angeles in addition to recent romantic experiences. Where Telefone was reflective and child-like in its jazzy hip-hop, Room 25 is vibrantly outgoing, introducing the world to a new Noname as well commenting on present political issues. With tremendous vocals, iridescent keyboards, and neo-soul grooves to back her potent words, Noname has weaved her way to the top of the rap game. Room 25 is soaked with the talent of a rising star, and, ironically, makes Noname a hard name to forget.<br />
&#8211; <a href="TEMP">John Peterson</a></em><br /></p></div>
</li>
</ol>
<p><iframe src="https://open.spotify.com/embed/user/wptsradio/playlist/40djmk11QnzgSW7LsHNy6S" width="300" height="380" frameborder="0" allowtransparency="true" allow="encrypted-media"></iframe></p>
          <nav class="pagination group">
                      </nav><!--/.pagination-->
        </div>

        <div class="sharrre-container">
	<span>Share</span>
  	   <div id="twitter" data-url="https://wptsradio.org/wptss-top-50-albums-of-2018/" data-text="WPTS&#8217;s Top 50 Albums of 2018" data-title="Tweet"><a class="box" href="#"><div class="count" href="#"><i class="fa fa-plus"></i></div><div class="share"><i class="fa fa-twitter"></i></div></a></div>
    	   <div id="facebook" data-url="https://wptsradio.org/wptss-top-50-albums-of-2018/" data-text="WPTS&#8217;s Top 50 Albums of 2018" data-title="Like"></div>
    	   <div id="googleplus" data-url="https://wptsradio.org/wptss-top-50-albums-of-2018/" data-text="WPTS&#8217;s Top 50 Albums of 2018" data-title="+1"></div>
      </div><!--/.sharrre-container-->

<script type="text/javascript">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</script>
        <div class="clear"></div>
      </div><!--/.entry-->

    </div><!--/.post-inner-->
  </article><!--/.post-->

<div class="clear"></div>

<p class="post-tags"><span>Tags:</span> <a href="https://wptsradio.org/tag/beach-house/" rel="tag">Beach House</a><a href="https://wptsradio.org/tag/blood-orange/" rel="tag">Blood Orange</a><a href="https://wptsradio.org/tag/boy-pablo/" rel="tag">Boy Pablo</a><a href="https://wptsradio.org/tag/boygenius/" rel="tag">boygenius</a><a href="https://wptsradio.org/tag/brockhampton/" rel="tag">Brockhampton</a><a href="https://wptsradio.org/tag/car-seat-headrest/" rel="tag">car seat headrest</a><a href="https://wptsradio.org/tag/caroline-rose/" rel="tag">Caroline Rose</a><a href="https://wptsradio.org/tag/courtney-barnett/" rel="tag">Courtney Barnett</a><a href="https://wptsradio.org/tag/current-joys/" rel="tag">current joys</a><a href="https://wptsradio.org/tag/denzel-curry/" rel="tag">Denzel Curry</a><a href="https://wptsradio.org/tag/earl-sweatshirt/" rel="tag">Earl Sweatshirt</a><a href="https://wptsradio.org/tag/end-of-the-year/" rel="tag">End of the year</a><a href="https://wptsradio.org/tag/gobbinjr/" rel="tag">Gobbinjr</a><a href="https://wptsradio.org/tag/guerilla-toss/" rel="tag">Guerilla Toss</a><a href="https://wptsradio.org/tag/homesafe/" rel="tag">homesafe</a><a href="https://wptsradio.org/tag/jack-stauber/" rel="tag">Jack Stauber</a><a href="https://wptsradio.org/tag/janelle-monae/" rel="tag">Janelle Monae</a><a href="https://wptsradio.org/tag/jid/" rel="tag">JID</a><a href="https://wptsradio.org/tag/jpegmafia/" rel="tag">JPEGMAFIA</a><a href="https://wptsradio.org/tag/kali-uchis/" rel="tag">Kali Uchis</a><a href="https://wptsradio.org/tag/kero-kero-bonito/" rel="tag">Kero Kero Bonito</a><a href="https://wptsradio.org/tag/lala-lala/" rel="tag">Lala Lala</a><a href="https://wptsradio.org/tag/lets-eat-grandma/" rel="tag">Lets Eat Grandma</a><a href="https://wptsradio.org/tag/list/" rel="tag">list</a><a href="https://wptsradio.org/tag/liz-cooper-and-the-stampede/" rel="tag">Liz Cooper and the Stampede</a><a href="https://wptsradio.org/tag/lucy-dacus/" rel="tag">Lucy Dacus</a><a href="https://wptsradio.org/tag/mac-miller/" rel="tag">Mac Miller</a><a href="https://wptsradio.org/tag/merce-lemon/" rel="tag">merce lemon</a><a href="https://wptsradio.org/tag/mid-air-thief/" rel="tag">Mid-Air Thief</a><a href="https://wptsradio.org/tag/mitski/" rel="tag">Mitski</a><a href="https://wptsradio.org/tag/mom-jeans/" rel="tag">Mom Jeans</a><a href="https://wptsradio.org/tag/mourn/" rel="tag">Mourn</a><a href="https://wptsradio.org/tag/music-staff/" rel="tag">music staff</a><a href="https://wptsradio.org/tag/noname/" rel="tag">Noname</a><a href="https://wptsradio.org/tag/oh-sees/" rel="tag">oh sees</a><a href="https://wptsradio.org/tag/parquet-courts-2/" rel="tag">parquet courts</a><a href="https://wptsradio.org/tag/playboi-carti/" rel="tag">Playboi Carti</a><a href="https://wptsradio.org/tag/pusha-t/" rel="tag">Pusha-T</a><a href="https://wptsradio.org/tag/rejjie-snow/" rel="tag">Rejjie Snow</a><a href="https://wptsradio.org/tag/rivers-of-nihil/" rel="tag">Rivers of Nihil</a><a href="https://wptsradio.org/tag/saba/" rel="tag">Saba</a><a href="https://wptsradio.org/tag/save-face/" rel="tag">Save Face</a><a href="https://wptsradio.org/tag/sidney-gish/" rel="tag">Sidney Gish</a><a href="https://wptsradio.org/tag/snail-mail/" rel="tag">snail mail</a><a href="https://wptsradio.org/tag/soccer-mommy/" rel="tag">soccer mommy</a><a href="https://wptsradio.org/tag/sonder-bombs/" rel="tag">Sonder Bombs</a><a href="https://wptsradio.org/tag/spiritualized/" rel="tag">Spiritualized</a><a href="https://wptsradio.org/tag/the-punch-brothers/" rel="tag">The Punch Brothers</a><a href="https://wptsradio.org/tag/tierra-whack/" rel="tag">Tierra Whack</a><a href="https://wptsradio.org/tag/top-albums/" rel="tag">top albums</a><a href="https://wptsradio.org/tag/treble-nls/" rel="tag">Treble NLS</a><a href="https://wptsradio.org/tag/water-trash/" rel="tag">Water Trash</a><a href="https://wptsradio.org/tag/young-fathers/" rel="tag">Young Fathers</a><a href="https://wptsradio.org/tag/yves-tumor/" rel="tag">Yves Tumor</a></p>




<h4 class="heading">
	<i class="fa fa-hand-o-right"></i>You may also like...</h4>

<ul class="related-posts group">

		<li class="related post-hover">
		<article class="post-24874 post type-post status-publish format-standard has-post-thumbnail hentry category-music-cd-reviews category-general category-archives tag-brockhampton tag-hip-hop-2 tag-rca-records tag-zachary-falk">

			<div class="post-thumbnail">
				<a href="https://wptsradio.org/iridescence-by-brockhampton-review/" title="&#8220;iridescence&#8221; by BROCKHAMPTON &#8211; Review">
					<img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/11/https_2F2Fimages.genius.com2F5da37b77be2204a52bd0433c6650f563.1000x1000x1-520x245.png"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://wptsradio.org/wp-content/uploads/2018/11/https_2F2Fimages.genius.com2F5da37b77be2204a52bd0433c6650f563.1000x1000x1-520x245.png 520w, https://wptsradio.org/wp-content/uploads/2018/11/https_2F2Fimages.genius.com2F5da37b77be2204a52bd0433c6650f563.1000x1000x1-720x340.png 720w" data-sizes="(max-width: 520px) 100vw, 520px" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="https://wptsradio.org/iridescence-by-brockhampton-review/" rel="bookmark" title="&#8220;iridescence&#8221; by BROCKHAMPTON &#8211; Review">&#8220;iridescence&#8221; by BROCKHAMPTON &#8211; Review</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2018-11-10 14:26:47">November 10, 2018</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="https://wptsradio.org/author/music-content/" title="Posts by Music Content" rel="author">Music Content</a></span>
    </span> &middot; Published <span class="published">November 10, 2018</span>
    
  </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		<li class="related post-hover">
		<article class="post-24418 post type-post status-publish format-standard has-post-thumbnail hentry category-music-cd-reviews category-general category-archives tag-blood-orange tag-dev-hynes tag-domino tag-funk tag-london tag-new-york tag-pop tag-rb">

			<div class="post-thumbnail">
				<a href="https://wptsradio.org/negro-swan-by-blood-orange-review/" title="&#8220;Negro Swan&#8221; by Blood Orange &#8211; Review">
					<img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2018/09/blood-orange_negro-swan-520x245.jpg"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://wptsradio.org/wp-content/uploads/2018/09/blood-orange_negro-swan-520x245.jpg 520w, https://wptsradio.org/wp-content/uploads/2018/09/blood-orange_negro-swan-720x340.jpg 720w" data-sizes="(max-width: 520px) 100vw, 520px" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="https://wptsradio.org/negro-swan-by-blood-orange-review/" rel="bookmark" title="&#8220;Negro Swan&#8221; by Blood Orange &#8211; Review">&#8220;Negro Swan&#8221; by Blood Orange &#8211; Review</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2018-09-20 08:55:09">September 20, 2018</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="https://wptsradio.org/author/music/" title="Posts by Music" rel="author">Music</a></span>
    </span> &middot; Published <span class="published">September 20, 2018</span>
    
  </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		<li class="related post-hover">
		<article class="post-20115 post type-post status-publish format-standard has-post-thumbnail hentry category-music-cd-reviews category-general category-archives tag-album-reviews tag-oh-sees tag-ryan-hartman">

			<div class="post-thumbnail">
				<a href="https://wptsradio.org/album-review-oh-sees-orc/" title="Album Review: Oh Sees &#8211; Orc">
					<img  width="520" height="245"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://wptsradio.org/wp-content/uploads/2017/09/unnamed-2-520x245.jpg"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" data-srcset="https://wptsradio.org/wp-content/uploads/2017/09/unnamed-2-520x245.jpg 520w, https://wptsradio.org/wp-content/uploads/2017/09/unnamed-2-720x340.jpg 720w" data-sizes="(max-width: 520px) 100vw, 520px" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="https://wptsradio.org/album-review-oh-sees-orc/" rel="bookmark" title="Album Review: Oh Sees &#8211; Orc">Album Review: Oh Sees &#8211; Orc</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2017-09-14 15:36:23">September 14, 2017</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="https://wptsradio.org/author/music/" title="Posts by Music" rel="author">Music</a></span>
    </span> &middot; Published <span class="published">September 14, 2017</span>
    
  </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		
</ul><!--/.post-related-->



<section id="comments" class="themeform">

	
					<!-- comments open, no comments -->
		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/wptss-top-50-albums-of-2018/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://wptsradio.org/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='25444' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>			</form>
			</div><!-- #respond -->
	
</section><!--/#comments-->          </div><!--/.pad-->
        </section><!--/.content-->
          

	<div class="sidebar s1 collapsed" data-position="left" data-layout="col-3cm" data-sb-id="s1">

		<a class="sidebar-toggle" title="Expand Sidebar"><i class="fa icon-sidebar-toggle"></i></a>

		<div class="sidebar-content">

			  			<div class="sidebar-top group">
                        <p>Follow:</p>
          
          <ul class="social-links"><li><a rel="nofollow" class="social-tooltip"  title="YouTube" href="https://www.youtube.com/user/921WPTS" target="_blank"  style="color:#ff0000"><i class="fa fa-youtube-play"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Twitter" href="https://twitter.com/WPTSRadio" target="_blank"  style="color:#00aced"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Facebook" href="https://www.facebook.com/wptsradiofm/" target="_blank"  style="color:#3b5998"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Instagram" href="https://www.instagram.com/wptsradio/" target="_blank"  style="color:#e95950"><i class="fa fa-instagram"></i></a></li></ul>  			</div>
			
				<ul class="post-nav group">
		<li class="next"></li>
		<li class="previous"><a href="https://wptsradio.org/holy-hell-by-architects-review-2/" rel="prev"><i class="fa fa-chevron-left"></i><strong>Previous story</strong> <span>&#8220;Holy Hell&#8221; by Architects &#8211; Review</span></a></li>
	</ul>

			
			<div id="custom_html-17" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><h3>Click below to listen</h3>
<a href=http://audio.wpts.pitt.edu:8000/wpts_live_VBRs.mp3"  onclick="window.open('http://audio.wpts.pitt.edu:8000/wpts_live_VBRs.mp3', 'newwindow', 'width=300, height=250'); return false;"><img src="https://wptsradio.org/wp-content/uploads/2015/02/listen_now.gif" alt="Click here to listen now!"/></div></div><div id="text-11" class="widget widget_text">			<div class="textwidget"><strong>Now Playing</strong>

<a class="twitter-timeline" href="https://twitter.com/WPTSPlaylist" data-widget-id="659458741423730688">Tweets by @WPTSPlaylist</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
		</div><div id="text-5" class="widget widget_text"><h3 class="widget-title">WPTS Top 10</h3>			<div class="textwidget"><p><img src="https://f4.bcbits.com/img/a2337835939_16.jpg" width="200" height="200" alt="Mitski - Be the Cowboy" class="aligncenter size-medium" /></p>
<p>➊ Mitski <em>Be the Cowboy</em><br />
➋ Swearin' <em>Fall Into The Sun</em><br />
➌ Liz Cooper And The Stampede <em>Window Flowers</em><br />
➍ Water Trash <em>No Dice</em><br />
➎ Carl Broemel<em>Wished Out</em><br />
➏ Murder by Death <em>The Other Shore</em><br />
➐The Hills And The Rivers <em>The Fool & The Magician</em><br />
➑ Kuwaisiana <em>Chapter 1</em><br />
➒ Tomberlin <em>At Weddings</em><br />
➓ Shannen <em>Mating Surfaces</em></p>
<p><a href="https://wptsradio.org/charts/">View the full Top Thirty</a></p>
</div>
		</div><div id="custom_html-13" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://publicfiles.fcc.gov/fm-profile/wpts-fm" target="_blank">WPTS Public File</a> </div></div>
		</div><!--/.sidebar-content-->

	</div><!--/.sidebar-->

	<div class="sidebar s2 collapsed" data-position="right" data-layout="col-3cm" data-sb-id="s2">

	<a class="sidebar-toggle" title="Expand Sidebar"><i class="fa icon-sidebar-toggle"></i></a>

	<div class="sidebar-content">

		  		<div class="sidebar-top group">
  			<p>More</p>
  		</div>
		
		
		<div id="search-4" class="widget widget_search"><h3 class="widget-title">Search</h3><form method="get" class="searchform themeform" action="https://wptsradio.org/">
	<div>
		<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
	</div>
</form></div><div id="custom_html-11" class="widget_text widget widget_custom_html"><h3 class="widget-title">Schedule</h3><div class="textwidget custom-html-widget"><iframe src="https://www.google.com/calendar/embed?showTitle=0&amp;showNav=0&amp;showDate=0&amp;showPrint=0&amp;showTabs=0&amp;showCalendars=0&amp;showTz=0&amp;mode=AGENDA&amp;height=400&amp;wkst=1&amp;bgcolor=%23FF4FFF&amp;src=webwpts%40gmail.com&amp;color=%23182C57&amp;ctz=America%2FNew_York" style=" border-width:0 " width="200" height="400" frameborder="0" scrolling="yes"></iframe></div></div><div id="text-7" class="widget widget_text">			<div class="textwidget"><a href="https://wptsradio.org/djshowapplication/"><img src="http://wptsradio.org/wp-content/uploads/2015/02/radio-show-app.gif"/></a></div>
		</div><div id="custom_html-20" class="widget_text widget widget_custom_html"><h3 class="widget-title">Alumni Links</h3><div class="textwidget custom-html-widget"><a href="https://wptsradio.org/alumni-show-application/">Alumni Show Application</a></br>
<a href="https://wptsradio.org/alumni-playlist-submission/">Alumni Playlist Submission</a>
<a href="https://wptsradio.org/alumni-spotlight-application/">Alumni Spotlight Application</a>
</div></div><div id="text-12" class="widget widget_text"><h3 class="widget-title">Live DJ Request Form</h3>			<div class="textwidget"><a href="http://wptsradio.org/live-dj/"><img src=" http://wptsradio.org/wp-content/uploads/2014/06/lvieDJrequestform.jpg"></a></div>
		</div><div id="custom_html-15" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://www.buffaloexchange.com/"><img src="https://wptsradio.org/wp-content/uploads/2017/05/BuffaloLogo-bw-lessAngle-Wbub-NoShadow.png"></a>

<a href="http://www.foxspizza.com/locations/pa/pittsburgh/lawrenceville-pa-357/index.html">
<img src="https://wptsradio.org/wp-content/uploads/2018/09/Lawrencevile.jpg"></a>
</div></div>
	</div><!--/.sidebar-content-->

</div><!--/.sidebar-->

        </div><!--/.main-inner-->
      </div><!--/.main-->
    </div><!--/.container-inner-->
  </div><!--/.container-->
    <footer id="footer">

    
    
    
    <section class="container" id="footer-bottom">
      <div class="container-inner">

        <a id="back-to-top" href="#"><i class="fa fa-angle-up"></i></a>

        <div class="pad group">

          <div class="grid one-half">
                        
            <div id="copyright">
                              <p>WPTS Radio &copy; 2019. All Rights Reserved.</p>
                          </div><!--/#copyright-->

                                                          <div id="credit" style="">
                    <p>Powered by&nbsp;<a class="fa fa-wordpress" title="Powered by WordPress" href="https://wordpress.org/" target="_blank"></a> - Designed with the&nbsp;<a href="https://presscustomizr.com/hueman/" title="Hueman theme">Hueman theme</a></p>
                  </div><!--/#credit-->
                          
          </div>

          <div class="grid one-half last">
                          <ul class="social-links"><li><a rel="nofollow" class="social-tooltip"  title="YouTube" href="https://www.youtube.com/user/921WPTS" target="_blank"  style="color:#ff0000"><i class="fa fa-youtube-play"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Twitter" href="https://twitter.com/WPTSRadio" target="_blank"  style="color:#00aced"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Facebook" href="https://www.facebook.com/wptsradiofm/" target="_blank"  style="color:#3b5998"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Instagram" href="https://www.instagram.com/wptsradio/" target="_blank"  style="color:#e95950"><i class="fa fa-instagram"></i></a></li></ul>                      </div>

        </div><!--/.pad-->

      </div><!--/.container-inner-->
    </section><!--/.container-->

  </footer><!--/#footer-->

</div><!--/#wrapper-->

<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/wptsradio.org\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"https:\/\/wptsradio.org\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","recaptchaEmpty":"Please verify that you are not a robot.","sending":"Sending ..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.4'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/jquery/ui/spinner.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/jquery/ui/effect-shake.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/hueman-addons/addons/assets/front/js/jQuerySharrre.min.js?ver=4.8.8'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/wp-file-upload/vendor/datetimepicker/jquery-ui-timepicker-addon.min.js?ver=4.8.8'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":false,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"1","extLinksTargetExt":"1","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"1","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":false,"mobile":false},"isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_always","mobile":"stick_always"},"isDevMode":"","ajaxUrl":"https:\/\/wptsradio.org\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"08a6378044"},"userStarted":{"with":"with|3.3.10","on":{"date":"2017-10-20 14:53:36","timezone_type":3,"timezone":"America\/New_York"}},"isWelcomeNoteOn":"","welcomeContent":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/themes/hueman/assets/front/js/scripts.min.js?ver=3.3.22'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/comment-reply.min.js?ver=4.8.8'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/google-calendar-events/assets/js/vendor/jquery.qtip.min.js?ver=3.1.10'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/google-calendar-events/assets/js/vendor/moment.min.js?ver=3.1.10'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/google-calendar-events/assets/js/vendor/moment-timezone-with-data.min.js?ver=3.1.10'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var simcal_default_calendar = {"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"244cf82f0f","locale":"en_US","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};
var simcal_default_calendar = {"ajax_url":"\/wp-admin\/admin-ajax.php","nonce":"244cf82f0f","locale":"en_US","text_dir":"ltr","months":{"full":["January","February","March","April","May","June","July","August","September","October","November","December"],"short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"]},"days":{"full":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]},"meridiem":{"AM":"AM","am":"am","PM":"PM","pm":"pm"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/google-calendar-events/assets/js/default-calendar.min.js?ver=3.1.10'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-content/plugins/google-calendar-events/assets/js/vendor/imagesloaded.pkgd.min.js?ver=3.1.10'></script>
<script type='text/javascript' src='https://wptsradio.org/wp-includes/js/wp-embed.min.js?ver=4.8.8'></script>
<!--[if lt IE 9]>
<script src="https://wptsradio.org/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script>
<![endif]-->
</body>
</html>